Ad Blocker Excessive Filtering

Incident Report for Chaturbate

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 07:01 MST

Monitoring

We have identified and responded to an issue today with a commit made to a pattern list that backs several popular ad blockers. If you are experiencing issues in loading content, try disabling your ad block extensions while the fix is propagating.
Posted Apr 21, 2025 - 14:51 MST
This incident affected: Main (Chaturbate Website, Chat).