Site outage

Incident Report for Chaturbate

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 07:51 MST

Monitoring

Currently monitoring
Posted Dec 05, 2025 - 02:17 MST

Identified

Cloudflare is currently having issues with their network.
Posted Dec 05, 2025 - 02:12 MST

Investigating

We are currently investigating an issue with Cloudflare’s network
Posted Dec 05, 2025 - 02:09 MST
This incident affected: Main (Chaturbate Website) and Cloudflare Global Video Ingest, Cloudflare Network.