Yoti.com Age Verification Service outage is impacting age verification for some users

Incident Report for Chaturbate

Resolved

The upstream provider has resolved its connectivity issues.
Posted May 18, 2026 - 13:20 MST

Monitoring

Yoti, a provider of Age Verification services, is experiencing a site and API outage (see: https://status.yoti.com/)

This has caused us to be unable to process Age Verification using this service.

We see some additional secondary effects on our queue processing services but have mitigated these and are currently monitoring the situation.

Site is otherwise operating normally.
Posted May 11, 2026 - 10:46 MST
This incident affected: Main (Chaturbate Website).