Latest version of Firefox is causing site to not work for some users

Incident Report for Chaturbate

Update

We are continuing to monitor for any further issues.
Posted May 13, 2026 - 11:22 MST

Monitoring

We've identified a mitigation for affected users. It does require changing settings within Firefox itself.

For desktop users, you can do the following:

- Click the "shield" icon in the URL bar (aka Address bar)
- Switch "Enhanced Tracking Protection" to "off"

This should resolve the problem until we find a more permanent solution upstream.
Posted Apr 22, 2026 - 16:08 MST

Identified

We've identified an issue affecting some Firefox users. It appears to only affect Firefox users using Private Browsing mode.

We are currently investigating.
Posted Apr 22, 2026 - 15:13 MST
This incident affects: Main (Chaturbate Website).